summaryrefslogtreecommitdiffstats
path: root/bsp/meta-freescale/recipes-dpaa2/management-complex/management-complex_10.12.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-freescale/recipes-dpaa2/management-complex/management-complex_10.12.0.bb')
-rw-r--r--bsp/meta-freescale/recipes-dpaa2/management-complex/management-complex_10.12.0.bb40
1 files changed, 0 insertions, 40 deletions
diff --git a/bsp/meta-freescale/recipes-dpaa2/management-complex/management-complex_10.12.0.bb b/bsp/meta-freescale/recipes-dpaa2/management-complex/management-complex_10.12.0.bb
deleted file mode 100644
index 6b5d0a87..00000000
--- a/bsp/meta-freescale/recipes-dpaa2/management-complex/management-complex_10.12.0.bb
+++ /dev/null
@@ -1,40 +0,0 @@
-SUMMARY = "DPAA2 Management Complex Firmware"
-LICENSE = "NXP-Binary-EULA"
-LIC_FILES_CHKSUM = "file://NXP-Binary-EULA.txt;md5=afcb1213054384820390d410ab62105f"
-
-inherit deploy fsl-eula-unpack
-
-INHIBIT_DEFAULT_DEPS = "1"
-
-SRC_URI = "git://github.com/nxp/qoriq-mc-binary;fsl-eula=true;nobranch=1"
-SRCREV = "cdb5af4b25ec1ee3e9d26ece41efaa1556b28bac"
-
-S = "${WORKDIR}/git"
-
-REGLEX_ls2088a = "ls2088a"
-REGLEX_ls1088a = "ls1088a"
-REGLEX_lx2160a = "lx2160a"
-
-do_install () {
- install -d ${D}/boot
- install -m 755 ${S}/${REGLEX}/*.itb ${D}/boot
-}
-
-do_deploy () {
- install -d ${DEPLOYDIR}/mc_app
- install -m 755 ${S}/${REGLEX}/*.itb ${DEPLOYDIR}/mc_app
- # make a symlink to the latest binary
- for mc_binary in `ls ${DEPLOYDIR}/mc_app |sort`;do
- ln -sfT ${mc_binary} ${DEPLOYDIR}/mc_app/mc.itb
- done
-}
-addtask deploy before do_build after do_install
-
-PACKAGES += "${PN}-image"
-FILES_${PN}-image += "/boot"
-
-INHIBIT_PACKAGE_STRIP = "1"
-
-COMPATIBLE_MACHINE = "(qoriq-arm64)"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-