summaryrefslogtreecommitdiffstats
path: root/bsp/meta-freescale/recipes-extended/tsntool/tsntool_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-freescale/recipes-extended/tsntool/tsntool_git.bb')
-rw-r--r--bsp/meta-freescale/recipes-extended/tsntool/tsntool_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/bsp/meta-freescale/recipes-extended/tsntool/tsntool_git.bb b/bsp/meta-freescale/recipes-extended/tsntool/tsntool_git.bb
new file mode 100644
index 00000000..5694e91c
--- /dev/null
+++ b/bsp/meta-freescale/recipes-extended/tsntool/tsntool_git.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Configure TSN funtionalitie"
+DESCRIPTION = "A tool to configure TSN funtionalities in user space"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ef58f855337069acd375717db0dbbb6d"
+
+DEPENDS = "cjson libnl readline"
+
+inherit pkgconfig
+
+SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/tsntool;protocol=https;nobranch=1"
+SRCREV = "ca2d8fb348bb54960d706177108c43ae213e0063"
+
+S = "${WORKDIR}/git"
+
+do_configure[depends] += "virtual/kernel:do_shared_workdir"
+
+do_compile_prepend() {
+ mkdir -p ${S}/include/linux
+ cp -r ${STAGING_KERNEL_DIR}/include/uapi/linux/tsn.h ${S}/include/linux
+}
+do_install() {
+ install -d ${D}${bindir} ${D}${libdir}
+ install -m 0755 ${S}/tsntool ${D}${bindir}
+ install -m 0755 ${S}/libtsn.so ${D}${libdir}
+}
+
+PACKAGES = "${PN}-dbg ${PN}"
+FILES_${PN} = "${libdir}/libtsn.so ${bindir}/*"
+INSANE_SKIP_${PN} += "file-rdeps rpaths dev-so"
+COMPATIBLE_MACHINE = "(qoriq)"
+PARALLEL_MAKE = ""