summaryrefslogtreecommitdiffstats
path: root/bsp/meta-freescale/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.0.p2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-freescale/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.0.p2.0.bb')
-rw-r--r--bsp/meta-freescale/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.0.p2.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/bsp/meta-freescale/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.0.p2.0.bb b/bsp/meta-freescale/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.0.p2.0.bb
new file mode 100644
index 00000000..4c9015e9
--- /dev/null
+++ b/bsp/meta-freescale/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_6.4.0.p2.0.bb
@@ -0,0 +1,26 @@
+# Copyright (C) 2015-2016 Freescale Semiconductor
+# Copyright 2017-2018 NXP
+
+SUMMARY = "Kernel loadable module for Vivante GPU"
+DESCRIPTION = "Builds the Vivante GPU kernel driver as a loadable kernel module, \
+allowing flexibility to use a newer graphics release with an older kernel."
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+
+SRCBRANCH = "lf-5.4.y"
+LOCALVERSION = "-${SRCBRANCH}"
+KERNEL_SRC ?= "git://source.codeaurora.org/external/imx/linux-imx.git;protocol=https"
+SRC_URI = " \
+ ${KERNEL_SRC};branch=${SRCBRANCH};subpath=drivers/mxc/gpu-viv;destsuffix=git/src \
+ file://Add-makefile.patch \
+"
+SRCREV = "f8118585ee3c7025265b28985fdfe0af96a84466"
+
+S = "${WORKDIR}/git"
+
+inherit module
+
+EXTRA_OEMAKE += "CONFIG_MXC_GPU_VIV=m"
+
+KERNEL_MODULE_AUTOLOAD = "galcore"
+COMPATIBLE_MACHINE = "(imx)"