summaryrefslogtreecommitdiffstats
path: root/bsp/meta-freescale/recipes-kernel/linux/linux-imx-headers_5.4.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-freescale/recipes-kernel/linux/linux-imx-headers_5.4.3.bb')
-rw-r--r--bsp/meta-freescale/recipes-kernel/linux/linux-imx-headers_5.4.3.bb78
1 files changed, 78 insertions, 0 deletions
diff --git a/bsp/meta-freescale/recipes-kernel/linux/linux-imx-headers_5.4.3.bb b/bsp/meta-freescale/recipes-kernel/linux/linux-imx-headers_5.4.3.bb
new file mode 100644
index 00000000..4257c41a
--- /dev/null
+++ b/bsp/meta-freescale/recipes-kernel/linux/linux-imx-headers_5.4.3.bb
@@ -0,0 +1,78 @@
+# Copyright 2017-2019 NXP
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+SUMMARY = "Installs i.MX-specific kernel headers"
+DESCRIPTION = "Installs i.MX-specific kernel headers to userspace. \
+New headers are installed in ${includedir}/imx."
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
+
+SRCBRANCH = "lf-5.4.y"
+LOCALVERSION = "-1.0.0"
+SRC_URI = "git://source.codeaurora.org/external/imx/linux-imx.git;protocol=https;branch=${SRCBRANCH}"
+SRCREV = "f8118585ee3c7025265b28985fdfe0af96a84466"
+
+S = "${WORKDIR}/git"
+
+do_configure[noexec] = "1"
+
+do_compile[noexec] = "1"
+
+IMX_UAPI_HEADERS = " \
+ dma-buf.h \
+ hantrodec.h \
+ hx280enc.h \
+ ion.h \
+ ipu.h \
+ isl29023.h \
+ mxc_asrc.h \
+ mxc_dcic.h \
+ mxc_mlb.h \
+ mxc_sim_interface.h \
+ mxc_v4l2.h \
+ mxcfb.h \
+ pxp_device.h \
+ pxp_dma.h \
+ version.h \
+ videodev2.h \
+"
+
+do_install() {
+ # We install all headers inside of B so we can copy only the
+ # whitelisted ones, and there is no risk of a new header to be
+ # installed by mistake.
+ oe_runmake headers_install INSTALL_HDR_PATH=${B}${exec_prefix}
+
+ # Kernel should not be exporting this header
+ rm -f ${D}${exec_prefix}/include/scsi/scsi.h
+
+ # The ..install.cmd conflicts between various configure runs
+ find ${D}${includedir} -name ..install.cmd | xargs rm -f
+
+ # FIXME: The ion.h is still on staging so "promote" it for now
+ cp ${S}/drivers/staging/android/uapi/ion.h ${B}${includedir}/linux
+
+ # Install whitelisted headers only
+ for h in ${IMX_UAPI_HEADERS}; do
+ install -D -m 0644 ${B}${includedir}/linux/$h \
+ ${D}${includedir}/imx/linux/$h
+ done
+}
+
+# Allow to build empty main package, this is required in order for -dev package
+# to be propagated into the SDK
+#
+# Without this setting the RDEPENDS in other recipes fails to find this
+# package, therefore causing the -dev package also to be skipped effectively not
+# populating it into SDK
+ALLOW_EMPTY_${PN} = "1"
+
+INHIBIT_DEFAULT_DEPS = "1"
+DEPENDS += "unifdef-native bison-native rsync-native"
+
+PACKAGE_ARCH = "${MACHINE_SOCARCH}"
+
+# Restrict this recipe to NXP BSP only, this recipe is not compatible
+# with mainline BSP
+COMPATIBLE_HOST = '(null)'
+COMPATIBLE_HOST_use-nxp-bsp = '.*'