summaryrefslogtreecommitdiffstats
path: root/bsp/meta-freescale/recipes-kernel/linux/linux-imx_5.4.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-freescale/recipes-kernel/linux/linux-imx_5.4.3.bb')
-rw-r--r--bsp/meta-freescale/recipes-kernel/linux/linux-imx_5.4.3.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/bsp/meta-freescale/recipes-kernel/linux/linux-imx_5.4.3.bb b/bsp/meta-freescale/recipes-kernel/linux/linux-imx_5.4.3.bb
new file mode 100644
index 00000000..6c042184
--- /dev/null
+++ b/bsp/meta-freescale/recipes-kernel/linux/linux-imx_5.4.3.bb
@@ -0,0 +1,35 @@
+# Copyright 2013-2016 (C) Freescale Semiconductor
+# Copyright 2017-2019 (C) NXP
+# Copyright 2018 (C) O.S. Systems Software LTDA.
+# Released under the MIT license (see COPYING.MIT for the terms)
+#
+# SPDX-License-Identifier: MIT
+#
+
+SUMMARY = "Linux Kernel provided and supported by NXP"
+DESCRIPTION = "Linux Kernel provided and supported by NXP with focus on \
+i.MX Family Reference Boards. It includes support for many IPs such as GPU, VPU and IPU."
+
+require recipes-kernel/linux/linux-imx.inc
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
+
+DEPENDS += "lzop-native bc-native"
+
+SRCBRANCH = "lf-5.4.y"
+LOCALVERSION = "-1.0.0"
+SRCREV = "f8118585ee3c7025265b28985fdfe0af96a84466"
+
+# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
+# required by kernel-yocto.bbclass.
+#
+# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
+# should be updated once patchlevel is merged.
+LINUX_VERSION = "5.4.3"
+
+SRC_URI += "file://0001-perf-Make-perf-able-to-build-with-latest-libbfd.patch"
+
+DEFAULT_PREFERENCE = "1"
+
+COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"