summaryrefslogtreecommitdiffstats
path: root/bsp/meta-raspberrypi/recipes-bsp/u-boot/libubootenv_%.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-raspberrypi/recipes-bsp/u-boot/libubootenv_%.bbappend')
-rw-r--r--bsp/meta-raspberrypi/recipes-bsp/u-boot/libubootenv_%.bbappend12
1 files changed, 12 insertions, 0 deletions
diff --git a/bsp/meta-raspberrypi/recipes-bsp/u-boot/libubootenv_%.bbappend b/bsp/meta-raspberrypi/recipes-bsp/u-boot/libubootenv_%.bbappend
new file mode 100644
index 00000000..22d1bdc4
--- /dev/null
+++ b/bsp/meta-raspberrypi/recipes-bsp/u-boot/libubootenv_%.bbappend
@@ -0,0 +1,12 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI_append_rpi = " \
+ file://fw_env.config \
+"
+
+DEPENDS_append_rpi = " rpi-u-boot-scr"
+
+do_install_append_rpi () {
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
+}