summaryrefslogtreecommitdiffstats
path: root/bsp/meta-raspberrypi/recipes-core/packagegroups/packagegroup-rpi-test.bb
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-raspberrypi/recipes-core/packagegroups/packagegroup-rpi-test.bb')
-rw-r--r--bsp/meta-raspberrypi/recipes-core/packagegroups/packagegroup-rpi-test.bb13
1 files changed, 6 insertions, 7 deletions
diff --git a/bsp/meta-raspberrypi/recipes-core/packagegroups/packagegroup-rpi-test.bb b/bsp/meta-raspberrypi/recipes-core/packagegroups/packagegroup-rpi-test.bb
index 91593469..87de3558 100644
--- a/bsp/meta-raspberrypi/recipes-core/packagegroups/packagegroup-rpi-test.bb
+++ b/bsp/meta-raspberrypi/recipes-core/packagegroups/packagegroup-rpi-test.bb
@@ -2,6 +2,8 @@ DESCRIPTION = "RaspberryPi Test Packagegroup"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
inherit packagegroup
COMPATIBLE_MACHINE = "^rpi$"
@@ -11,21 +13,18 @@ OMXPLAYER = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', 'omxpl
RDEPENDS_${PN} = "\
${OMXPLAYER} \
bcm2835-tests \
- wiringpi \
rpio \
rpi-gpio \
pi-blaster \
- python-rtimu \
- python-sense-hat \
+ python3-rtimu \
+ python3-sense-hat \
connman \
connman-client \
- crda \
+ wireless-regdb-static \
bluez5 \
"
RRECOMMENDS_${PN} = "\
- bigbuckbunny-1080p \
- bigbuckbunny-480p \
- bigbuckbunny-720p \
+ ${@bb.utils.contains("BBFILE_COLLECTIONS", "meta-multimedia", "bigbuckbunny-1080p bigbuckbunny-480p bigbuckbunny-720p", "", d)} \
${MACHINE_EXTRA_RRECOMMENDS} \
"