summaryrefslogtreecommitdiffstats
path: root/bsp/meta-ti/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'bsp/meta-ti/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb')
-rw-r--r--bsp/meta-ti/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/bsp/meta-ti/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb b/bsp/meta-ti/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb
new file mode 100644
index 00000000..6e17c4aa
--- /dev/null
+++ b/bsp/meta-ti/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb
@@ -0,0 +1,39 @@
+SUMMARY = "PRU Ethernet firmware for AM65xx SR2.0"
+
+LICENSE = "TI-TFL"
+LIC_FILES_CHKSUM = "file://LICENSE.ti;md5=b5aebf0668bdf95621259288c4a46d76"
+
+PV = "2.2.0.1+2.2.0.2-rc1"
+
+CLEANBROKEN = "1"
+
+COMPATIBLE_MACHINE = "am65xx-evm"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+SRCREV = "ea4bf53ba0a4a30bb7e0e8b6138fdb22fe50372a"
+BRANCH ?= "ti-linux-firmware"
+
+SRC_URI = "git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=git;branch=${BRANCH}"
+
+S = "${WORKDIR}/git"
+
+TARGET = " \
+ am65x-sr2-pru0-prueth-fw.elf \
+ am65x-sr2-pru1-prueth-fw.elf \
+ am65x-sr2-rtu0-prueth-fw.elf \
+ am65x-sr2-rtu1-prueth-fw.elf \
+ am65x-sr2-txpru0-prueth-fw.elf \
+ am65x-sr2-txpru1-prueth-fw.elf \
+"
+
+do_install() {
+ install -d ${D}${base_libdir}/firmware/ti-pruss
+ for f in ${TARGET}; do
+ install -m 0644 ${S}/ti-pruss/$f ${D}${base_libdir}/firmware/ti-pruss/$f
+ done
+}
+
+FILES_${PN} = "${base_libdir}/firmware"
+
+INSANE_SKIP_${PN} = "arch"