summaryrefslogtreecommitdiffstats
path: root/external/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-cpp/files/Add-C-as-a-build-language.patch
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-cpp/files/Add-C-as-a-build-language.patch')
-rw-r--r--external/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-cpp/files/Add-C-as-a-build-language.patch110
1 files changed, 110 insertions, 0 deletions
diff --git a/external/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-cpp/files/Add-C-as-a-build-language.patch b/external/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-cpp/files/Add-C-as-a-build-language.patch
new file mode 100644
index 00000000..7cf150f6
--- /dev/null
+++ b/external/meta-iot-cloud/recipes-aws/aws-iot-device-sdk-cpp/files/Add-C-as-a-build-language.patch
@@ -0,0 +1,110 @@
+From ec1e8828ce3067d6902c04a75952a3535292040c Mon Sep 17 00:00:00 2001
+From: Scott Ware <scott.r.ware@intel.com>
+Date: Fri, 8 Dec 2017 10:41:10 +0000
+Subject: [PATCH 1/5] Add C as a build language
+
+Signed-off-by: Scott Ware <scott.r.ware@intel.com>
+---
+ CMakeLists.txt | 2 +-
+ cli/CMakeLists.txt | 2 +-
+ samples/Discovery/CMakeLists.txt | 2 +-
+ samples/PubSub/CMakeLists.txt | 2 +-
+ samples/ShadowDelta/CMakeLists.txt | 2 +-
+ samples/StoryRobotArm/CMakeLists.txt | 4 ++--
+ samples/StorySwitch/CMakeLists.txt | 4 ++--
+ 7 files changed, 9 insertions(+), 9 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index ad8a4e1..9df255f 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,5 +1,5 @@
+ cmake_minimum_required(VERSION 3.2 FATAL_ERROR)
+-project(aws-iot-sdk-cpp CXX)
++project(aws-iot-sdk-cpp C CXX)
+ option(BUILD_SHARED_LIBRARY "Build the library as a shared object, will build it as a static library otherwise" NO)
+
+ ######################################
+diff --git a/cli/CMakeLists.txt b/cli/CMakeLists.txt
+index da4f25d..dfa5040 100644
+--- a/cli/CMakeLists.txt
++++ b/cli/CMakeLists.txt
+@@ -1,5 +1,5 @@
+ cmake_minimum_required(VERSION 3.2 FATAL_ERROR)
+-project(aws-iot-cli CXX)
++project(aws-iot-cli C CXX)
+
+ ######################################
+ # Section : Disable in-source builds #
+diff --git a/samples/Discovery/CMakeLists.txt b/samples/Discovery/CMakeLists.txt
+index 8df8d35..3147841 100644
+--- a/samples/Discovery/CMakeLists.txt
++++ b/samples/Discovery/CMakeLists.txt
+@@ -1,5 +1,5 @@
+ cmake_minimum_required(VERSION 3.2 FATAL_ERROR)
+-project(aws-iot-cpp-samples CXX)
++project(aws-iot-cpp-samples C CXX)
+
+ ######################################
+ # Section : Disable in-source builds #
+diff --git a/samples/PubSub/CMakeLists.txt b/samples/PubSub/CMakeLists.txt
+index 62ffd05..33531d0 100644
+--- a/samples/PubSub/CMakeLists.txt
++++ b/samples/PubSub/CMakeLists.txt
+@@ -1,5 +1,5 @@
+ cmake_minimum_required(VERSION 3.2 FATAL_ERROR)
+-project(aws-iot-cpp-samples CXX)
++project(aws-iot-cpp-samples C CXX)
+
+ ######################################
+ # Section : Disable in-source builds #
+diff --git a/samples/ShadowDelta/CMakeLists.txt b/samples/ShadowDelta/CMakeLists.txt
+index 98aa3b9..1ebabed 100644
+--- a/samples/ShadowDelta/CMakeLists.txt
++++ b/samples/ShadowDelta/CMakeLists.txt
+@@ -1,5 +1,5 @@
+ cmake_minimum_required(VERSION 3.2 FATAL_ERROR)
+-project(aws-iot-cpp-samples CXX)
++project(aws-iot-cpp-samples C CXX)
+
+ ######################################
+ # Section : Disable in-source builds #
+diff --git a/samples/StoryRobotArm/CMakeLists.txt b/samples/StoryRobotArm/CMakeLists.txt
+index 215df18..13dd16f 100644
+--- a/samples/StoryRobotArm/CMakeLists.txt
++++ b/samples/StoryRobotArm/CMakeLists.txt
+@@ -1,5 +1,5 @@
+ cmake_minimum_required(VERSION 3.2 FATAL_ERROR)
+-project(aws-iot-cpp-samples CXX)
++project(aws-iot-cpp-samples C CXX)
+
+ ######################################
+ # Section : Disable in-source builds #
+@@ -84,4 +84,4 @@ endif ()
+ #########################
+
+ set(NETWORK_WRAPPER_DEST_TARGET ${ROBOT_ARM_SAMPLE_TARGET_NAME})
+-include(${PROJECT_SOURCE_DIR}/../../network/CMakeLists.txt.in)
+\ No newline at end of file
++include(${PROJECT_SOURCE_DIR}/../../network/CMakeLists.txt.in)
+diff --git a/samples/StorySwitch/CMakeLists.txt b/samples/StorySwitch/CMakeLists.txt
+index e612567..0096bad 100644
+--- a/samples/StorySwitch/CMakeLists.txt
++++ b/samples/StorySwitch/CMakeLists.txt
+@@ -1,5 +1,5 @@
+ cmake_minimum_required(VERSION 3.2 FATAL_ERROR)
+-project(aws-iot-cpp-samples CXX)
++project(aws-iot-cpp-samples C CXX)
+
+ ######################################
+ # Section : Disable in-source builds #
+@@ -84,4 +84,4 @@ endif ()
+ #########################
+
+ set(NETWORK_WRAPPER_DEST_TARGET ${SWITCH_SAMPLE_TARGET_NAME})
+-include(${PROJECT_SOURCE_DIR}/../../network/CMakeLists.txt.in)
+\ No newline at end of file
++include(${PROJECT_SOURCE_DIR}/../../network/CMakeLists.txt.in)
+--
+1.9.1
+