summaryrefslogtreecommitdiffstats
path: root/external/meta-iot-cloud/recipes-devtools/python/python3-janus_0.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-iot-cloud/recipes-devtools/python/python3-janus_0.4.0.bb')
-rw-r--r--external/meta-iot-cloud/recipes-devtools/python/python3-janus_0.4.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/external/meta-iot-cloud/recipes-devtools/python/python3-janus_0.4.0.bb b/external/meta-iot-cloud/recipes-devtools/python/python3-janus_0.4.0.bb
new file mode 100644
index 00000000..f8fa41fb
--- /dev/null
+++ b/external/meta-iot-cloud/recipes-devtools/python/python3-janus_0.4.0.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Mixed sync-async queue to interoperate between asyncio tasks and classic threads"
+AUTHOR = "Andrew Svetlov"
+HOMEPAGE = "https://github.com/aio-libs/janus/"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=23878c357ebb4c8ce1109be365043349"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-asyncio \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-typing \
+"
+
+PR = "r0"
+
+SRC_URI[sha256sum] = "cfc221683160b91b35bae1917e2957b78dad10a2e634f4f8ed119ed72e2a88ef"