summaryrefslogtreecommitdiffstats
path: root/external/meta-iot-cloud/recipes-devtools/python/python3-mapbox_0.18.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-iot-cloud/recipes-devtools/python/python3-mapbox_0.18.0.bb')
-rw-r--r--external/meta-iot-cloud/recipes-devtools/python/python3-mapbox_0.18.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/external/meta-iot-cloud/recipes-devtools/python/python3-mapbox_0.18.0.bb b/external/meta-iot-cloud/recipes-devtools/python/python3-mapbox_0.18.0.bb
new file mode 100644
index 00000000..652710f1
--- /dev/null
+++ b/external/meta-iot-cloud/recipes-devtools/python/python3-mapbox_0.18.0.bb
@@ -0,0 +1,23 @@
+SUMMARY = "A Python client for Mapbox services"
+HOMEPAGE = "https://pypi.org/project/mapbox/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+SRC_URI[md5sum] = "7e5a55af6054f9d0681313855814512c"
+SRC_URI[sha256sum] = "3e9a098524a6b855f39fd5e773fb21526ef9660291f12b147e98fd44c7573e0b"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ python3-boto3 \
+ python3-cachecontrol \
+ python3-dateutil \
+ python3-iso3166 \
+ python3-polyline \
+ python3-requests \
+ python3-uritemplate \
+"
+
+RDEPENDS_${PN} += "python3-core python3-json python3-netclient python3-numbers"
+
+BBCLASSEXTEND = "native nativesdk"