summaryrefslogtreecommitdiffstats
path: root/external/meta-iot-cloud/recipes-devtools/python/python3-requests-unixsocket_0.2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-iot-cloud/recipes-devtools/python/python3-requests-unixsocket_0.2.0.bb')
-rw-r--r--external/meta-iot-cloud/recipes-devtools/python/python3-requests-unixsocket_0.2.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/external/meta-iot-cloud/recipes-devtools/python/python3-requests-unixsocket_0.2.0.bb b/external/meta-iot-cloud/recipes-devtools/python/python3-requests-unixsocket_0.2.0.bb
new file mode 100644
index 00000000..587d6d21
--- /dev/null
+++ b/external/meta-iot-cloud/recipes-devtools/python/python3-requests-unixsocket_0.2.0.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Use requests to talk HTTP via a UNIX domain socket"
+HOMEPAGE = "https://github.com/msabramo/requests-unixsocket"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
+
+inherit pypi setuptools3
+
+DEPENDS += "\
+ python3-pbr-native \
+"
+
+RDEPENDS_${PN} += "\
+ python3-requests \
+ python3-urllib3 \
+"
+
+RDEPENDS_${PN} += " \
+ python3-io \
+"
+
+SRC_URI[sha256sum] = "9e5c1a20afc3cf786197ae59c79bcdb0e7565f218f27df5f891307ee8817c1ea"