summaryrefslogtreecommitdiffstats
path: root/external/meta-iot-cloud/recipes-support/http-parser/http-parser_2.8.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-iot-cloud/recipes-support/http-parser/http-parser_2.8.1.bb')
-rw-r--r--external/meta-iot-cloud/recipes-support/http-parser/http-parser_2.8.1.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/external/meta-iot-cloud/recipes-support/http-parser/http-parser_2.8.1.bb b/external/meta-iot-cloud/recipes-support/http-parser/http-parser_2.8.1.bb
new file mode 100644
index 00000000..8fd2fba9
--- /dev/null
+++ b/external/meta-iot-cloud/recipes-support/http-parser/http-parser_2.8.1.bb
@@ -0,0 +1,30 @@
+SUMMARY = "Parser for HTTP messages written in C"
+HOMEPAGE = "https://github.com/nodejs/http-parser"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE-MIT;md5=9bfa835d048c194ab30487af8d7b3778"
+
+SRC_URI = "git://github.com/nodejs/http-parser.git"
+SRCREV = "54f55a2f02a823e5f5c87abe853bb76d1170718d"
+
+PR = "r0"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = "\
+ 'CFLAGS=${CFLAGS} -Wno-implicit-fallthrough' \
+"
+
+do_configure[noexec] = "1"
+
+do_compile() {
+ oe_runmake library package
+}
+
+do_install() {
+ oe_libinstall -C ${S} -so libhttp_parser ${D}${libdir}
+
+ install -d ${D}${includedir}
+ install -m 0644 ${S}/*.h ${D}${includedir}
+}
+
+BBCLASSEXTEND = "native nativesdk"