summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server-native.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-openembedded/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server-native.bb')
-rw-r--r--external/meta-openembedded/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server-native.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/external/meta-openembedded/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server-native.bb b/external/meta-openembedded/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server-native.bb
new file mode 100644
index 00000000..681a61c3
--- /dev/null
+++ b/external/meta-openembedded/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server-native.bb
@@ -0,0 +1,23 @@
+require ${BPN}.inc
+
+inherit native
+
+DEPENDS = "glib-2.0-native"
+
+# build native helpers
+do_compile() {
+ cd ${S}/src/camel
+ sed -i 's:#include "evolution-data-server-config.h"::g' camel-gen-tables.c
+ ${CC} -o ${B}/camel-gen-tables camel-gen-tables.c ${CFLAGS} ${LDFLAGS}
+
+ LDFLAGS_glib=`pkg-config glib-2.0 --libs`
+ CFLAGS_glib=`pkg-config glib-2.0 --cflags`
+ cd ${S}/src/addressbook/libebook-contacts
+ sed -i 's:#include "evolution-data-server-config.h"::g' gen-western-table.c
+ ${CC} -o ${B}/gen-western-table gen-western-table.c ${CFLAGS} ${CFLAGS_glib} ${LDFLAGS} ${LDFLAGS_glib}
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 755 ${B}/* ${D}${bindir}
+}