summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-initramfs/recipes-core/images/initramfs-kexecboot-klibc-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-openembedded/meta-initramfs/recipes-core/images/initramfs-kexecboot-klibc-image.bb')
-rw-r--r--external/meta-openembedded/meta-initramfs/recipes-core/images/initramfs-kexecboot-klibc-image.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/external/meta-openembedded/meta-initramfs/recipes-core/images/initramfs-kexecboot-klibc-image.bb b/external/meta-openembedded/meta-initramfs/recipes-core/images/initramfs-kexecboot-klibc-image.bb
new file mode 100644
index 00000000..3a8d9f74
--- /dev/null
+++ b/external/meta-openembedded/meta-initramfs/recipes-core/images/initramfs-kexecboot-klibc-image.bb
@@ -0,0 +1,12 @@
+require initramfs-kexecboot-image.bb
+
+SUMMARY = "Initramfs image for kexecboot kernel (klibc-static binaries)"
+
+# We really need just kexecboot, kexec and ubiattach
+# statically compiled against klibc
+IMAGE_INSTALL = "kexecboot-klibc kexec-klibc ubiattach-klibc"
+
+python () {
+ if d.getVar('TARGET_ARCH') == "nios2":
+ raise bb.parse.SkipRecipe("'nios2' not supported arch")
+}