summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-initramfs/recipes-core/images
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-openembedded/meta-initramfs/recipes-core/images')
-rw-r--r--external/meta-openembedded/meta-initramfs/recipes-core/images/initramfs-debug-image.bb20
-rw-r--r--external/meta-openembedded/meta-initramfs/recipes-core/images/initramfs-kexecboot-image.bb26
-rw-r--r--external/meta-openembedded/meta-initramfs/recipes-core/images/initramfs-kexecboot-klibc-image.bb12
-rw-r--r--external/meta-openembedded/meta-initramfs/recipes-core/images/meta-initramfs-image.bb6
4 files changed, 64 insertions, 0 deletions
diff --git a/external/meta-openembedded/meta-initramfs/recipes-core/images/initramfs-debug-image.bb b/external/meta-openembedded/meta-initramfs/recipes-core/images/initramfs-debug-image.bb
new file mode 100644
index 00000000..c3dcd2b8
--- /dev/null
+++ b/external/meta-openembedded/meta-initramfs/recipes-core/images/initramfs-debug-image.bb
@@ -0,0 +1,20 @@
+# Simple initramfs image. Mostly used for live images.
+DESCRIPTION = "Small image capable of booting a device. The kernel includes \
+the Minimal RAM-based Initial Root Filesystem (initramfs), which one can use \
+to check the hardware efficiently."
+
+PACKAGE_INSTALL = "initramfs-debug busybox base-passwd ${ROOTFS_BOOTSTRAP_INSTALL}"
+
+# Do not pollute the initrd image with rootfs features
+IMAGE_FEATURES = ""
+
+export IMAGE_BASENAME = "initramfs-debug-image"
+IMAGE_LINGUAS = ""
+
+IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
+inherit core-image
+
+IMAGE_ROOTFS_SIZE = "8192"
+IMAGE_ROOTFS_EXTRA_SPACE = "0"
+
+BAD_RECOMMENDATIONS += "busybox-syslog"
diff --git a/external/meta-openembedded/meta-initramfs/recipes-core/images/initramfs-kexecboot-image.bb b/external/meta-openembedded/meta-initramfs/recipes-core/images/initramfs-kexecboot-image.bb
new file mode 100644
index 00000000..9a686f36
--- /dev/null
+++ b/external/meta-openembedded/meta-initramfs/recipes-core/images/initramfs-kexecboot-image.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Initramfs image for kexecboot kernel"
+DESCRIPTION = "This image provides kexecboot (linux as bootloader) and helpers."
+
+inherit image
+
+IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
+
+# avoid circular dependencies
+EXTRA_IMAGEDEPENDS = ""
+KERNELDEPMODDEPEND = ""
+
+# We really need just kexecboot, kexec and ubiattach
+IMAGE_INSTALL = "kexecboot kexec mtd-utils-ubifs"
+
+# Do not pollute the initrd image with rootfs features
+IMAGE_FEATURES = ""
+
+IMAGE_LINGUAS = ""
+
+FEED_DEPLOYDIR_BASE_URI = ""
+LDCONFIGDEPEND = ""
+IMAGE_ROOTFS_EXTRA_SPACE = "0"
+
+# disable runtime dependency on run-postinsts -> update-rc.d
+ROOTFS_BOOTSTRAP_INSTALL = ""
+
diff --git a/external/meta-openembedded/meta-initramfs/recipes-core/images/initramfs-kexecboot-klibc-image.bb b/external/meta-openembedded/meta-initramfs/recipes-core/images/initramfs-kexecboot-klibc-image.bb
new file mode 100644
index 00000000..3a8d9f74
--- /dev/null
+++ b/external/meta-openembedded/meta-initramfs/recipes-core/images/initramfs-kexecboot-klibc-image.bb
@@ -0,0 +1,12 @@
+require initramfs-kexecboot-image.bb
+
+SUMMARY = "Initramfs image for kexecboot kernel (klibc-static binaries)"
+
+# We really need just kexecboot, kexec and ubiattach
+# statically compiled against klibc
+IMAGE_INSTALL = "kexecboot-klibc kexec-klibc ubiattach-klibc"
+
+python () {
+ if d.getVar('TARGET_ARCH') == "nios2":
+ raise bb.parse.SkipRecipe("'nios2' not supported arch")
+}
diff --git a/external/meta-openembedded/meta-initramfs/recipes-core/images/meta-initramfs-image.bb b/external/meta-openembedded/meta-initramfs/recipes-core/images/meta-initramfs-image.bb
new file mode 100644
index 00000000..4c041eb5
--- /dev/null
+++ b/external/meta-openembedded/meta-initramfs/recipes-core/images/meta-initramfs-image.bb
@@ -0,0 +1,6 @@
+SUMMARY = "meta-initramfs build test image"
+
+IMAGE_INSTALL = "packagegroup-core-boot \
+ packagegroup-meta-initramfs"
+
+inherit core-image