summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-networking/recipes-support/ntop/ntop/embed-libs.patch
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-openembedded/meta-networking/recipes-support/ntop/ntop/embed-libs.patch')
-rw-r--r--external/meta-openembedded/meta-networking/recipes-support/ntop/ntop/embed-libs.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/external/meta-openembedded/meta-networking/recipes-support/ntop/ntop/embed-libs.patch b/external/meta-openembedded/meta-networking/recipes-support/ntop/ntop/embed-libs.patch
new file mode 100644
index 00000000..2d1ab737
--- /dev/null
+++ b/external/meta-openembedded/meta-networking/recipes-support/ntop/ntop/embed-libs.patch
@@ -0,0 +1,20 @@
+Use --embed option so that it can return libpython as well
+
+% ../recipe-sysroot-native/usr/bin/python3-native/python3-config --libs --embed
+-lpython3.8 -lcrypt -lpthread -ldl -lutil -lm -lm
+[kraj@apollo /mnt/b/yoe/build/tmp/work/cortexa7t2hf-neon-vfpv4-yoe-linux-gnueabi/ntop/5.0.1-r0/ntop-5.0.1]
+% ../recipe-sysroot-native/usr/bin/python3-native/python3-config --libs
+-lcrypt -lpthread -ldl -lutil -lm -lm
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/configure.in
++++ b/configure.in
+@@ -1463,7 +1463,7 @@ dnl>
+ fi
+
+ if test "x$PYTHON_CONFIG" != "x"; then
+- PYTHON_LIBS="`$PYTHON_CONFIG --libs`"
++ PYTHON_LIBS="`$PYTHON_CONFIG --libs --embed`"
+ if test "x$PYTHON_LIBS" = "x"; then
+ AC_MSG_RESULT(Python[-devel] support is present but misconfigured)
+ else