summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-oe/conf/layer.conf
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-openembedded/meta-oe/conf/layer.conf')
-rw-r--r--external/meta-openembedded/meta-oe/conf/layer.conf20
1 files changed, 18 insertions, 2 deletions
diff --git a/external/meta-openembedded/meta-oe/conf/layer.conf b/external/meta-openembedded/meta-oe/conf/layer.conf
index 23c10ce3..adcec830 100644
--- a/external/meta-openembedded/meta-oe/conf/layer.conf
+++ b/external/meta-openembedded/meta-oe/conf/layer.conf
@@ -23,16 +23,25 @@ BBFILE_PATTERN_openembedded-layer := "^${LAYERDIR}/"
BBFILE_PRIORITY_openembedded-layer = "6"
+# only activates content when identified layers are present,
+# to ensure yocto compatibility check pass
+BBFILES_DYNAMIC += " \
+meta-python:${LAYERDIR}/dynamic-layers/meta-python/recipes-*/*/*.bb \
+perl-layer:${LAYERDIR}/dynamic-layers/perl-layer/recipes-*/*/*.bb \
+"
+
# This should only be incremented on significant changes that will
# cause compatibility issues with other layers
LAYERVERSION_openembedded-layer = "1"
LAYERDEPENDS_openembedded-layer = "core"
-LAYERSERIES_COMPAT_openembedded-layer = "thud"
+LAYERSERIES_COMPAT_openembedded-layer = "thud warrior zeus dunfell"
LICENSE_PATH += "${LAYERDIR}/licenses"
+PREFERRED_RPROVIDER_libdevmapper = "lvm2"
+
SIGGEN_EXCLUDERECIPES_ABISAFE += " \
mplayer-common \
fbset-modes \
@@ -47,8 +56,13 @@ SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS += " \
usb-modeswitch-data->usb-modeswitch \
lmsensors->lmsensors-config \
phoronix-test-suite->bash \
- phoronix-test-suite->python \
+ phoronix-test-suite->python3 \
phoronix-test-suite->php \
+ phoronix-test-suite->lsb-release \
+ phoronix-test-suite->util-linux \
+ phoronix-test-suite->busybox \
+ phoronix-test-suite->shared-mime-info \
+ phoronix-test-suite->desktop-file-utils \
"
# ttf.inc inherits fontcache which adds fontconfig-utils to RDEPENDS
@@ -65,7 +79,9 @@ SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS += " \
ttf-liberation-sans-narrow->fontconfig \
ttf-lklug->fontconfig \
ttf-lohit->fontconfig \
+ ttf-noto-emoji->fontconfig \
ttf-pt-sans->fontconfig \
+ ttf-roboto->fontconfig \
ttf-mplus->fontconfig \
ttf-sazanami->fontconfig \
ttf-tlwg->fontconfig \