summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-oe/recipes-extended/iotop/iotop_0.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-openembedded/meta-oe/recipes-extended/iotop/iotop_0.6.bb')
-rw-r--r--external/meta-openembedded/meta-oe/recipes-extended/iotop/iotop_0.6.bb18
1 files changed, 10 insertions, 8 deletions
diff --git a/external/meta-openembedded/meta-oe/recipes-extended/iotop/iotop_0.6.bb b/external/meta-openembedded/meta-oe/recipes-extended/iotop/iotop_0.6.bb
index 94643cd2..3a597218 100644
--- a/external/meta-openembedded/meta-oe/recipes-extended/iotop/iotop_0.6.bb
+++ b/external/meta-openembedded/meta-oe/recipes-extended/iotop/iotop_0.6.bb
@@ -4,24 +4,26 @@ DESCRIPTION = "iotop does for I/O usage what top(1) does for CPU usage. \
a table of current I/O usage by processes on the system."
HOMEPAGE = "http://guichaz.free.fr/iotop/"
-
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4"
-SRC_URI = "http://guichaz.free.fr/iotop/files/${BP}.tar.bz2"
-SRC_URI[md5sum] = "5ef9456b26d7694abf3101a72e1e0d1d"
-SRC_URI[sha256sum] = "3adea2a24eda49bbbaeb4e6ed2042355b441dbd7161e883067a02bfc8dcef75b"
+PV .= "+git${SRCPV}"
+
+SRCREV = "1bfb3bc70febb1ffb95146b6dcd65257228099a3"
+SRC_URI = "git://repo.or.cz/iotop.git"
+
+S = "${WORKDIR}/git"
UPSTREAM_CHECK_URI = "http://repo.or.cz/iotop.git/tags"
UPSTREAM_CHECK_REGEX = "iotop-(?P<pver>\d+(\.\d+)+)"
-inherit distutils
+inherit distutils3
do_install_append() {
rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/site.pyo || true
rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/site.py || true
}
-RDEPENDS_${PN} = "python-curses python-textutils \
- python-codecs python-ctypes python-pprint \
- python-shell python-subprocess"
+RDEPENDS_${PN} = "python3-curses \
+ python3-codecs python3-ctypes python3-pprint \
+ python3-shell python3-core"