summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-oe/recipes-support/cli11/cli11_1.8.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-openembedded/meta-oe/recipes-support/cli11/cli11_1.8.0.bb')
-rw-r--r--external/meta-openembedded/meta-oe/recipes-support/cli11/cli11_1.8.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/external/meta-openembedded/meta-oe/recipes-support/cli11/cli11_1.8.0.bb b/external/meta-openembedded/meta-oe/recipes-support/cli11/cli11_1.8.0.bb
new file mode 100644
index 00000000..dd129cbe
--- /dev/null
+++ b/external/meta-openembedded/meta-oe/recipes-support/cli11/cli11_1.8.0.bb
@@ -0,0 +1,23 @@
+SUMMARY = "C++11 command line parser"
+DESCRIPTION = "A command line parser for C++11 and beyond that provides a rich feature set with a simple and intuitive interface."
+HOMEPAGE = "https://github.com/CLIUtils/CLI11"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b73927b18d5c6cd8d2ed28a6ad539733"
+SRCREV = "13becaddb657eacd090537719a669d66d393b8b2"
+PV .= "+git${SRCPV}"
+
+SRC_URI += "gitsm://github.com/CLIUtils/CLI11 \
+ file://0001-Add-CLANG_TIDY-check.patch \
+ file://0001-Use-GNUInstallDirs-instead-of-hard-coded-path.patch \
+ "
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+inherit ptest
+
+EXTRA_OECMAKE += "-DCLANG_TIDY=OFF"
+DEPENDS += "boost"
+
+# cli11 is a header only C++ library, so the main package will be empty.
+RDEPENDS_${PN}-dev = ""