summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-oe/recipes-support/cpprest/cpprest/disable-outside-tests.patch
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-openembedded/meta-oe/recipes-support/cpprest/cpprest/disable-outside-tests.patch')
-rw-r--r--external/meta-openembedded/meta-oe/recipes-support/cpprest/cpprest/disable-outside-tests.patch201
1 files changed, 93 insertions, 108 deletions
diff --git a/external/meta-openembedded/meta-oe/recipes-support/cpprest/cpprest/disable-outside-tests.patch b/external/meta-openembedded/meta-oe/recipes-support/cpprest/cpprest/disable-outside-tests.patch
index 2dff0d97..5f1f8a9f 100644
--- a/external/meta-openembedded/meta-oe/recipes-support/cpprest/cpprest/disable-outside-tests.patch
+++ b/external/meta-openembedded/meta-oe/recipes-support/cpprest/cpprest/disable-outside-tests.patch
@@ -6,10 +6,10 @@ Forwarded: not-needed
Reviewed-By: Gianfranco Costamagna <locutusofborg@debian.org>
Last-Update: 2015-11-25
-Index: casablanca/Release/tests/functional/http/client/CMakeLists.txt
+Index: cpprest/Release/tests/functional/http/client/CMakeLists.txt
===================================================================
---- casablanca.orig/Release/tests/functional/http/client/CMakeLists.txt
-+++ casablanca/Release/tests/functional/http/client/CMakeLists.txt
+--- cpprest.orig/Release/tests/functional/http/client/CMakeLists.txt
++++ cpprest/Release/tests/functional/http/client/CMakeLists.txt
@@ -12,7 +12,6 @@
multiple_requests.cpp
oauth1_tests.cpp
@@ -18,125 +18,110 @@ Index: casablanca/Release/tests/functional/http/client/CMakeLists.txt
pipeline_stage_tests.cpp
progress_handler_tests.cpp
proxy_tests.cpp
-Index: casablanca/Release/tests/functional/http/client/authentication_tests.cpp
+Index: cpprest/Release/tests/functional/http/client/authentication_tests.cpp
===================================================================
---- casablanca.orig/Release/tests/functional/http/client/authentication_tests.cpp
-+++ casablanca/Release/tests/functional/http/client/authentication_tests.cpp
-@@ -663,15 +663,19 @@
- VERIFY_ARE_EQUAL(return_code, response.status_code());
- }
+--- cpprest.orig/Release/tests/functional/http/client/authentication_tests.cpp
++++ cpprest/Release/tests/functional/http/client/authentication_tests.cpp
+@@ -675,9 +675,9 @@
+ VERIFY_ARE_EQUAL(return_code, response.status_code());
+ }
-+/*
- TEST(auth_no_data)
- {
- auth_test_impl(false);
- }
-+*/
+- TEST(auth_no_data) { auth_test_impl(false); }
++ //TEST(auth_no_data) { auth_test_impl(false); }
-+/*
- TEST(unsuccessful_auth_with_basic_cred)
- {
- auth_test_impl(true);
- }
-+*/
+- TEST(unsuccessful_auth_with_basic_cred) { auth_test_impl(true); }
++ //TEST(unsuccessful_auth_with_basic_cred) { auth_test_impl(true); }
+
+ TEST_FIXTURE(uri_address, set_user_options_asio_http)
+ {
+@@ -695,6 +695,7 @@
+ VERIFY_ARE_EQUAL(200, response.status_code());
+ }
+
++ /*
+ TEST_FIXTURE(uri_address, set_user_options_asio_https)
+ {
+ handle_timeout([] {
+@@ -714,6 +715,7 @@
+ VERIFY_IS_FALSE(v.empty());
+ });
+ }
++ */
- TEST_FIXTURE(uri_address, set_user_options_asio_http)
- {
-@@ -692,7 +696,7 @@
- auto response = client.request(methods::GET).get();
- VERIFY_ARE_EQUAL(200, response.status_code());
- }
--
-+/*
- TEST_FIXTURE(uri_address, set_user_options_asio_https)
- {
- handle_timeout([]
-@@ -714,7 +718,7 @@
- VERIFY_IS_FALSE(v.empty());
- });
- }
--
-+*/
#endif
- } // SUITE(authentication_tests)
-Index: casablanca/Release/tests/functional/websockets/client/authentication_tests.cpp
+Index: cpprest/Release/tests/functional/websockets/client/authentication_tests.cpp
===================================================================
---- casablanca.orig/Release/tests/functional/websockets/client/authentication_tests.cpp
-+++ casablanca/Release/tests/functional/websockets/client/authentication_tests.cpp
-@@ -86,7 +86,7 @@
- }
- return false;
- }
--
-+/*
- TEST(ssl_test)
- {
- websocket_client client;
-@@ -122,7 +122,7 @@
- throw;
+--- cpprest.orig/Release/tests/functional/websockets/client/authentication_tests.cpp
++++ cpprest/Release/tests/functional/websockets/client/authentication_tests.cpp
+@@ -93,6 +93,7 @@ SUITE(authentication_tests)
+ return false;
}
- }
--
-+*/
- // These tests are specific to our websocketpp based implementation.
- #if !defined(__cplusplus_winrt)
-@@ -153,14 +153,15 @@
- throw;
++ /*
+ TEST(ssl_test)
+ {
+ websocket_client client;
+@@ -127,6 +128,7 @@ SUITE(authentication_tests)
+ throw;
+ }
}
- }
--
-+/*
- // Test specifically for server SignalR team hit interesting cases with.
- TEST(sni_with_older_server_test)
- {
- websocket_client client;
- sni_test_impl(client);
- }
--
-+*/
-+/*
- // WinRT doesn't expose option for disabling.
- // No stable server is available to reliably test this.
- // The configuration below relies on a timeout in the success case.
-@@ -188,7 +189,8 @@
- throw;
++ */
+
+ void handshake_error_test_impl(const ::utility::string_t& host)
+ {
+@@ -148,11 +150,11 @@ SUITE(authentication_tests)
+ }
}
- }
--
-+*/
-+/*
- // Winrt doesn't allow explicitly setting server host for SNI.
- TEST(sni_explicit_hostname)
- {
-@@ -199,7 +201,7 @@
- websocket_client client(config);
- sni_test_impl(client);
- }
--
-+*/
- void handshake_error_test_impl(const ::utility::string_t &host)
- {
- websocket_client client;
-Index: casablanca/Release/tests/functional/http/client/connections_and_errors.cpp
+
+- TEST(self_signed_cert) { handshake_error_test_impl(U("wss://self-signed.badssl.com/")); }
++ //TEST(self_signed_cert) { handshake_error_test_impl(U("wss://self-signed.badssl.com/")); }
+
+- TEST(hostname_mismatch) { handshake_error_test_impl(U("wss://wrong.host.badssl.com/")); }
++ //TEST(hostname_mismatch) { handshake_error_test_impl(U("wss://wrong.host.badssl.com/")); }
+
+- TEST(cert_expired) { handshake_error_test_impl(U("wss://expired.badssl.com/")); }
++ //TEST(cert_expired) { handshake_error_test_impl(U("wss://expired.badssl.com/")); }
+
+ } // SUITE(authentication_tests)
+
+Index: cpprest/Release/tests/functional/http/client/connections_and_errors.cpp
===================================================================
---- casablanca.orig/Release/tests/functional/http/client/connections_and_errors.cpp
-+++ casablanca/Release/tests/functional/http/client/connections_and_errors.cpp
-@@ -415,6 +415,7 @@
- }
+--- cpprest.orig/Release/tests/functional/http/client/connections_and_errors.cpp
++++ cpprest/Release/tests/functional/http/client/connections_and_errors.cpp
+@@ -408,6 +408,7 @@
+ }
#endif
-+/*
- // Try to connect to a server on a closed port and cancel the operation.
- TEST_FIXTURE(uri_address, cancel_bad_port)
- {
-@@ -446,7 +447,7 @@
++ /*
+ // Try to connect to a server on a closed port and cancel the operation.
+ TEST_FIXTURE(uri_address, cancel_bad_port)
+ {
+@@ -439,6 +440,7 @@
+
+ VERIFY_THROWS_HTTP_ERROR_CODE(t.get(), std::errc::operation_canceled);
+ }
++ */
- VERIFY_THROWS_HTTP_ERROR_CODE(t.get(), std::errc::operation_canceled);
- }
--
-+*/
} // SUITE(connections_and_errors)
- }}}}
+--- cpprest-2.10.16.orig/Release/tests/functional/http/client/redirect_tests.cpp
++++ cpprest-2.10.16/Release/tests/functional/http/client/redirect_tests.cpp
+@@ -159,7 +159,7 @@ SUITE(redirect_tests)
+ VERIFY_NO_THROWS(reply.get());
+ }
+ }
+-
++/*
+ TEST(does_not_follow_https_to_http_by_default)
+ {
+ handle_timeout([] {
+@@ -182,7 +182,7 @@ SUITE(redirect_tests)
+ );
+ });
+ }
+-
++*/
+ TEST_FIXTURE(uri_address, follows_permanent_redirect)
+ {
+ #if USING_WINHTTP