summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-oe/recipes-support/cpprest/cpprest_2.10.16.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-openembedded/meta-oe/recipes-support/cpprest/cpprest_2.10.16.bb')
-rw-r--r--external/meta-openembedded/meta-oe/recipes-support/cpprest/cpprest_2.10.16.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/external/meta-openembedded/meta-oe/recipes-support/cpprest/cpprest_2.10.16.bb b/external/meta-openembedded/meta-oe/recipes-support/cpprest/cpprest_2.10.16.bb
new file mode 100644
index 00000000..5d7dbd8b
--- /dev/null
+++ b/external/meta-openembedded/meta-oe/recipes-support/cpprest/cpprest_2.10.16.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Microsoft project for cloud-based client-server communication in native code using a modern asynchronous C++ API design."
+SECTION = "libs/network"
+HOMEPAGE = "https://github.com/Microsoft/cpprestsdk/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${S}/license.txt;md5=a2e15b954769218ff912468eecd6a02f"
+DEPENDS = "openssl websocketpp zlib boost brotli"
+
+EXTRA_OECMAKE = "-DCPPREST_EXPORT_DIR=cmake/cpprestsdk -DCPPREST_EXCLUDE_BROTLI=OFF -DWERROR=OFF"
+
+SRC_URI = "git://github.com/Microsoft/cpprestsdk.git;protocol=https;branch=master \
+ file://disable-float-tests.patch \
+ file://disable-outside-tests.patch "
+
+# tag 2.10.16
+SRCREV= "18212a2a7967e12d740bfb957e500892b3463c88"
+
+S = "${WORKDIR}/git"
+
+inherit cmake pkgconfig