summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-oe/recipes-support/dfu-util/dfu-util-native_0.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-openembedded/meta-oe/recipes-support/dfu-util/dfu-util-native_0.9.bb')
-rw-r--r--external/meta-openembedded/meta-oe/recipes-support/dfu-util/dfu-util-native_0.9.bb16
1 files changed, 13 insertions, 3 deletions
diff --git a/external/meta-openembedded/meta-oe/recipes-support/dfu-util/dfu-util-native_0.9.bb b/external/meta-openembedded/meta-oe/recipes-support/dfu-util/dfu-util-native_0.9.bb
index aeca23bf..feb16fa7 100644
--- a/external/meta-openembedded/meta-oe/recipes-support/dfu-util/dfu-util-native_0.9.bb
+++ b/external/meta-openembedded/meta-oe/recipes-support/dfu-util/dfu-util-native_0.9.bb
@@ -4,12 +4,22 @@ inherit native deploy
DEPENDS = "libusb1-native"
-SRC_URI += "file://0001-Revert-Makefile.am-Drop-static-dfu-util.patch"
+PACKAGECONFIG ??= ""
+
+PACKAGECONFIG[static] = "CFLAGS='${CFLAGS} -pthread -static',,"
-do_deploy[sstate-outputdirs] = "${DEPLOY_DIR_TOOLS}"
do_deploy() {
- install -m 0755 src/dfu-util_static ${DEPLOYDIR}/dfu-util-${PV}
+ install -m 0755 src/dfu-util ${DEPLOYDIR}/dfu-util-${PV}
rm -f ${DEPLOYDIR}/dfu-util
ln -sf ./dfu-util-${PV} ${DEPLOYDIR}/dfu-util
}
+
addtask deploy before do_package after do_install
+
+do_deploy[sstate-outputdirs] = "${DEPLOY_DIR_TOOLS}"
+# cleandirs should possibly be in deploy.bbclass but we need it
+do_deploy[cleandirs] = "${DEPLOYDIR}"
+# clear stamp-extra-info since MACHINE_ARCH is normally put there by
+# deploy.bbclass
+do_deploy[stamp-extra-info] = ""
+