summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-oe/recipes-support/fltk/fltk.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-openembedded/meta-oe/recipes-support/fltk/fltk.bb')
-rw-r--r--external/meta-openembedded/meta-oe/recipes-support/fltk/fltk.bb9
1 files changed, 6 insertions, 3 deletions
diff --git a/external/meta-openembedded/meta-oe/recipes-support/fltk/fltk.bb b/external/meta-openembedded/meta-oe/recipes-support/fltk/fltk.bb
index ec9e04be..09344cf7 100644
--- a/external/meta-openembedded/meta-oe/recipes-support/fltk/fltk.bb
+++ b/external/meta-openembedded/meta-oe/recipes-support/fltk/fltk.bb
@@ -2,10 +2,13 @@ require ${BPN}.inc
DEPENDS = "alsa-lib zlib jpeg libpng libxext libxft"
-inherit distro_features_check binconfig lib_package gtk-icon-cache mime
+inherit features_check binconfig lib_package gtk-icon-cache mime mime-xdg
REQUIRED_DISTRO_FEATURES = "x11"
-SRC_URI += "file://0003-CMake-build-Force-shared-libs-with-unsuffixed-names.patch"
+SRC_URI += " \
+ file://0003-CMake-build-Force-shared-libs-with-unsuffixed-names.patch \
+ file://0004-Fix-build-error-when-enable-package-config-examples.patch \
+"
EXTRA_OECMAKE = " \
-DOPTION_BUILD_SHARED_LIBS=ON \
@@ -17,7 +20,7 @@ EXTRA_OECMAKE = " \
PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'opengl', d)}"
-PACKAGECONFIG[examples] = "-DOPTION_BUILD_EXAMPLES=ON,-DOPTION_BUILD_EXAMPLES=OFF,"
+PACKAGECONFIG[examples] = "-DOPTION_BUILD_EXAMPLES=ON,-DOPTION_BUILD_EXAMPLES=OFF,fltk-native"
PACKAGECONFIG[cairo] = "-DOPTION_CAIRO=ON,-DOPTION_CAIRO=OFF,cairo"
PACKAGECONFIG[opengl] = "-DOPTION_USE_GL=ON,-DOPTION_USE_GL=OFF,virtual/libgl"
PACKAGECONFIG[xinerama] = "-DOPTION_USE_XINERAMA=ON,-DOPTION_USE_XINERAMA=OFF,libxinerama"