summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-oe/recipes-support/pidgin/pidgin/use_py3.patch
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-openembedded/meta-oe/recipes-support/pidgin/pidgin/use_py3.patch')
-rw-r--r--external/meta-openembedded/meta-oe/recipes-support/pidgin/pidgin/use_py3.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/external/meta-openembedded/meta-oe/recipes-support/pidgin/pidgin/use_py3.patch b/external/meta-openembedded/meta-oe/recipes-support/pidgin/pidgin/use_py3.patch
new file mode 100644
index 00000000..c7b4163c
--- /dev/null
+++ b/external/meta-openembedded/meta-oe/recipes-support/pidgin/pidgin/use_py3.patch
@@ -0,0 +1,20 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -1488,7 +1488,7 @@ AC_ARG_WITH([python],
+
+ if test "x$enable_dbus" = "xyes" || test "x$enable_consoleui" = "xyes" ; then
+ if test -z "$PYTHON" -o "x$PYTHON" = "xyes"; then
+- AC_PATH_PROG([PYTHON], [python], [no])
++ AC_PATH_PROG([PYTHON], [python3], [no])
+ fi
+
+ if test x"$PYTHON" = x"no" ; then
+@@ -1568,7 +1568,7 @@ dnl Check for Python headers (currently
+ dnl (Thanks to XChat)
+ if test "x$enable_consoleui" = "xyes" -a ! -z "$PYTHON" -a x"$PYTHON" != x"no" ; then
+ AC_MSG_CHECKING(for Python compile flags)
+- PKG_CHECK_MODULES(PY, python, [
++ PKG_CHECK_MODULES(PY, python3, [
+ AC_SUBST(PY_CFLAGS)
+ AC_SUBST(PY_LIBS)
+ ], [