summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-python/recipes-devtools/python/python3-pycparser_2.20.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-openembedded/meta-python/recipes-devtools/python/python3-pycparser_2.20.bb')
-rw-r--r--external/meta-openembedded/meta-python/recipes-devtools/python/python3-pycparser_2.20.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/external/meta-openembedded/meta-python/recipes-devtools/python/python3-pycparser_2.20.bb b/external/meta-openembedded/meta-python/recipes-devtools/python/python3-pycparser_2.20.bb
new file mode 100644
index 00000000..2a5f414b
--- /dev/null
+++ b/external/meta-openembedded/meta-python/recipes-devtools/python/python3-pycparser_2.20.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Parser of the C language, written in pure Python"
+HOMEPAGE = "https://github.com/eliben/pycparser"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86f1cedb4e6410a88ce8e30b91079169"
+
+SRC_URI[md5sum] = "b8f88de737db8c346ee8d31c07c7a25a"
+SRC_URI[sha256sum] = "2d475327684562c3a96cc71adf7dc8c4f0565175cf86b6d7a404ff4c771f15f0"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND = "native nativesdk"
+
+RDEPENDS_${PN}_class-target += "\
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-ply \
+ ${PYTHON_PN}-pprint \
+ cpp \
+ cpp-symlinks \
+ "