summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-python/recipes-devtools/python/python3-pyusb_1.0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-openembedded/meta-python/recipes-devtools/python/python3-pyusb_1.0.2.bb')
-rw-r--r--external/meta-openembedded/meta-python/recipes-devtools/python/python3-pyusb_1.0.2.bb14
1 files changed, 12 insertions, 2 deletions
diff --git a/external/meta-openembedded/meta-python/recipes-devtools/python/python3-pyusb_1.0.2.bb b/external/meta-openembedded/meta-python/recipes-devtools/python/python3-pyusb_1.0.2.bb
index 1ecede7c..44c24f42 100644
--- a/external/meta-openembedded/meta-python/recipes-devtools/python/python3-pyusb_1.0.2.bb
+++ b/external/meta-openembedded/meta-python/recipes-devtools/python/python3-pyusb_1.0.2.bb
@@ -1,2 +1,12 @@
-inherit setuptools3
-require python-pyusb.inc
+SUMMARY = "PyUSB provides USB access on the Python language"
+HOMEPAGE = "http://pyusb.sourceforge.net/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=51691ed11cc2c7ae93e383f60ed49b0f"
+DEPENDS += "libusb1"
+
+SRC_URI[md5sum] = "862b56452c64948c787ad8ef9498590b"
+SRC_URI[sha256sum] = "4e9b72cc4a4205ca64fbf1f3fff39a335512166c151ad103e55c8223ac147362"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND = "native nativesdk"