summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-python/recipes-devtools/python/python3-sh_1.12.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-openembedded/meta-python/recipes-devtools/python/python3-sh_1.12.14.bb')
-rw-r--r--external/meta-openembedded/meta-python/recipes-devtools/python/python3-sh_1.12.14.bb23
1 files changed, 21 insertions, 2 deletions
diff --git a/external/meta-openembedded/meta-python/recipes-devtools/python/python3-sh_1.12.14.bb b/external/meta-openembedded/meta-python/recipes-devtools/python/python3-sh_1.12.14.bb
index 812bd4b1..b7858734 100644
--- a/external/meta-openembedded/meta-python/recipes-devtools/python/python3-sh_1.12.14.bb
+++ b/external/meta-openembedded/meta-python/recipes-devtools/python/python3-sh_1.12.14.bb
@@ -1,5 +1,24 @@
-require python-sh.inc
-inherit setuptools3
+SUMMARY = "Python subprocess replacement"
+HOMEPAGE = "https://github.com/amoffat/sh"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=5317094292296f03405f59ae5f6544b6"
+
+SRC_URI[md5sum] = "a8351aef25d25f707c17e0a7a6280251"
+SRC_URI[sha256sum] = "b52bf5833ed01c7b5c5fb73a7f71b3d98d48e9b9b8764236237bdc7ecae850fc"
+
+PYPI_PACKAGE = "sh"
+
+inherit pypi setuptools3
RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-codecs \
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-resource \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-terminal \
+ ${PYTHON_PN}-tests \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-unixadmin \
"