summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-python/recipes-devtools/python/python3-spidev_3.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-openembedded/meta-python/recipes-devtools/python/python3-spidev_3.2.bb')
-rw-r--r--external/meta-openembedded/meta-python/recipes-devtools/python/python3-spidev_3.2.bb18
1 files changed, 16 insertions, 2 deletions
diff --git a/external/meta-openembedded/meta-python/recipes-devtools/python/python3-spidev_3.2.bb b/external/meta-openembedded/meta-python/recipes-devtools/python/python3-spidev_3.2.bb
index 610611e4..65679594 100644
--- a/external/meta-openembedded/meta-python/recipes-devtools/python/python3-spidev_3.2.bb
+++ b/external/meta-openembedded/meta-python/recipes-devtools/python/python3-spidev_3.2.bb
@@ -1,2 +1,16 @@
-inherit setuptools3
-require python-spidev.inc
+SUMMARY = "Python bindings for Linux SPI access through spidev"
+DESCRIPTION = "This project contains a python module for interfacing with SPI\
+devices from user space via the spidev linux kernel driver.\
+This is a modified version of the code originally found\
+[here](http://elk.informatik.fh-augsburg.de/da/da-49/trees/pyap7k/lang/py-spi)\
+All code is GPLv2 licensed unless explicitly stated otherwise."
+HOMEPAGE = "http://github.com/doceme/py-spidev"
+SECTION = "devel/python"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE.md;md5=54bdb9022ebb75ab68399cdaab97da60"
+SRCNAME = "spidev"
+
+SRC_URI[md5sum] = "f601676f1bb48b9aa3b3897f95216365"
+SRC_URI[sha256sum] = "09d2b5122f0dd79910713a11f9a0020f71537224bf829916def4fffc0ea59456"
+
+inherit pypi setuptools3