summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-python/recipes-devtools/python/python3-wtforms_2.2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-openembedded/meta-python/recipes-devtools/python/python3-wtforms_2.2.1.bb')
-rw-r--r--external/meta-openembedded/meta-python/recipes-devtools/python/python3-wtforms_2.2.1.bb17
1 files changed, 16 insertions, 1 deletions
diff --git a/external/meta-openembedded/meta-python/recipes-devtools/python/python3-wtforms_2.2.1.bb b/external/meta-openembedded/meta-python/recipes-devtools/python/python3-wtforms_2.2.1.bb
index add59cf7..2b7af626 100644
--- a/external/meta-openembedded/meta-python/recipes-devtools/python/python3-wtforms_2.2.1.bb
+++ b/external/meta-openembedded/meta-python/recipes-devtools/python/python3-wtforms_2.2.1.bb
@@ -1,2 +1,17 @@
+DESCRIPTION = "A flexible forms validation and rendering library for python web development."
+HOMEPAGE = "https://pypi.python.org/pypi/WTForms"
+SECTION = "devel/python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=c4660c132770d5d0a5757541f6b79493"
+
+SRC_URI[md5sum] = "41c0008dbe7bd98892c58f7457a46a4a"
+SRC_URI[sha256sum] = "0cdbac3e7f6878086c334aa25dc5a33869a3954e9d1e015130d65a69309b3b61"
+
+PYPI_PACKAGE = "WTForms"
+
inherit pypi setuptools3
-require python-wtforms.inc
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-netserver \
+ ${PYTHON_PN}-numbers \
+ "