summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-python/recipes-devtools/python/python3-xmltodict_0.12.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-openembedded/meta-python/recipes-devtools/python/python3-xmltodict_0.12.0.bb')
-rw-r--r--external/meta-openembedded/meta-python/recipes-devtools/python/python3-xmltodict_0.12.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/external/meta-openembedded/meta-python/recipes-devtools/python/python3-xmltodict_0.12.0.bb b/external/meta-openembedded/meta-python/recipes-devtools/python/python3-xmltodict_0.12.0.bb
new file mode 100644
index 00000000..d0788832
--- /dev/null
+++ b/external/meta-openembedded/meta-python/recipes-devtools/python/python3-xmltodict_0.12.0.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Makes working with XML feel like you are working with JSON"
+AUTHOR = "Martin Blech"
+HOMEPAGE = "https://github.com/martinblech/xmltodict"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=01441d50dc74476db58a41ac10cb9fa2"
+
+SRC_URI[md5sum] = "ddb2bd078cef4f7e3021a578034ad941"
+SRC_URI[sha256sum] = "50d8c638ed7ecb88d90561beedbf720c9b4e851a9fa6c47ebd64e99d166d8a21"
+
+PYPI_PACKAGE = "xmltodict"
+
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}