summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-webserver/recipes-httpd/cherokee/cherokee_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-openembedded/meta-webserver/recipes-httpd/cherokee/cherokee_git.bb')
-rw-r--r--external/meta-openembedded/meta-webserver/recipes-httpd/cherokee/cherokee_git.bb10
1 files changed, 8 insertions, 2 deletions
diff --git a/external/meta-openembedded/meta-webserver/recipes-httpd/cherokee/cherokee_git.bb b/external/meta-openembedded/meta-webserver/recipes-httpd/cherokee/cherokee_git.bb
index 3f7eae4c..74244679 100644
--- a/external/meta-openembedded/meta-webserver/recipes-httpd/cherokee/cherokee_git.bb
+++ b/external/meta-openembedded/meta-webserver/recipes-httpd/cherokee/cherokee_git.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
DEPENDS = "unzip-native libpcre openssl mysql5 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
-SRCREV = "75f041e2255e6dd0692db2f14611c2647dbe8425"
+SRCREV = "9a75e65b876bcc376cb6b379dca1f7ce4a055c59"
PV = "1.2.104+git${SRCPV}"
SRC_URI = "git://github.com/cherokee/webserver \
file://cherokee.init \
@@ -15,11 +15,12 @@ SRC_URI = "git://github.com/cherokee/webserver \
file://cherokee-install-configured.py-once.patch \
file://0001-configure.ac-Add-foreign-to-AM_INIT_AUTOMAKE.patch \
file://0001-make-Do-not-build-po-files.patch \
+ file://0001-common-internal.h-Define-LLONG_MAX-if-undefined.patch \
"
S = "${WORKDIR}/git"
-inherit autotools-brokensep pkgconfig binconfig update-rc.d systemd pythonnative
+inherit autotools-brokensep pkgconfig binconfig update-rc.d systemd ${@bb.utils.contains("BBFILE_COLLECTIONS", "meta-python2", "pythonnative", "", d)}
PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
PACKAGECONFIG[ffmpeg] = "--with-ffmpeg,--without-ffmpeg,libav"
@@ -69,3 +70,8 @@ RPROVIDES_${PN} += "${PN}-systemd"
RREPLACES_${PN} += "${PN}-systemd"
RCONFLICTS_${PN} += "${PN}-systemd"
SYSTEMD_SERVICE_${PN} = "cherokee.service"
+
+python() {
+ if 'meta-python2' not in d.getVar('BBFILE_COLLECTIONS').split():
+ raise bb.parse.SkipRecipe('Requires meta-python2 to be present.')
+}