summaryrefslogtreecommitdiffstats
path: root/external/meta-openembedded/meta-webserver/recipes-webadmin/netdata/netdata_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-openembedded/meta-webserver/recipes-webadmin/netdata/netdata_git.bb')
-rw-r--r--external/meta-openembedded/meta-webserver/recipes-webadmin/netdata/netdata_git.bb19
1 files changed, 11 insertions, 8 deletions
diff --git a/external/meta-openembedded/meta-webserver/recipes-webadmin/netdata/netdata_git.bb b/external/meta-openembedded/meta-webserver/recipes-webadmin/netdata/netdata_git.bb
index b0f16025..d6a5ce06 100644
--- a/external/meta-openembedded/meta-webserver/recipes-webadmin/netdata/netdata_git.bb
+++ b/external/meta-openembedded/meta-webserver/recipes-webadmin/netdata/netdata_git.bb
@@ -1,19 +1,17 @@
HOMEPAGE = "https://github.com/firehol/netdata/"
SUMMARY = "Real-time performance monitoring"
LICENSE = "GPLv3"
-LIC_FILES_CHKSUM = "file://LICENSE.md;md5=95b49e9ea979a337578f13c2a3ab9535 \
- file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
- "
+LIC_FILES_CHKSUM = "file://LICENSE;md5=fc9b848046ef54b5eaee6071947abd24"
SRC_URI = "git://github.com/firehol/netdata.git;protocol=https \
- file://0001-makefile-Do-not-build-contrib-dir.patch \
+ file://0002-Makefiles-does-not-build-contrib-dir.patch \
"
-SRCREV = "89ed309252981ddd50f697fde4fe93019cb3e652"
-PV = "1.8.0+git${SRCPV}"
+SRCREV = "588ce5a7b18999dfa66698cd3a2f005f7a3c31cf"
+PV = "1.17.0"
# patch to disable timeout because timeout are not available with actual version
# of core-utils
-SRC_URI += "file://0001-Correct-Timeout-issue.patch"
+SRC_URI += "file://0001-Correct-timeout-issue.patch"
# default netdata.conf for netdata configuration
SRC_URI += "file://netdata.conf"
@@ -25,7 +23,12 @@ S = "${WORKDIR}/git"
DEPENDS += "zlib util-linux"
-inherit pkgconfig autotools useradd systemd
+inherit pkgconfig autotools-brokensep useradd systemd
+
+LIBS_toolchain-clang_x86 = "-latomic"
+LIBS_riscv64 = "-latomic"
+LIBS_riscv32 = "-latomic"
+export LIBS
#systemd
SYSTEMD_PACKAGES = "${PN}"