summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-backports-init_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-backports-init_1.0.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-backports-init_1.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-backports-init_1.0.bb b/external/meta-python2/recipes-devtools/python/python-backports-init_1.0.bb
new file mode 100644
index 00000000..8b226aac
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-backports-init_1.0.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Helper package to avoid backports/__init__.py conflicts"
+DETAIL = "backports packages in python2 suffer from a flaw in the namespace \
+implementation and can conflict with each other. For OE purposes, at least \
+fix the conflicting install of .../site-packages/backports/__init__.py"
+AUTHOR = "Tim Orling <ticotimo@gmail.com>"
+SECTION = "devel/python"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+SRC_URI = "file://backports/__init__.py"
+
+inherit python-dir
+
+# provide to avoid warnings
+do_compile() {
+ :
+}
+
+do_install() {
+ install -d ${D}${PYTHON_SITEPACKAGES_DIR}/backports
+ install ${WORKDIR}/backports/__init__.py ${D}${PYTHON_SITEPACKAGES_DIR}/backports/
+}
+
+FILES_${PN} = "${PYTHON_SITEPACKAGES_DIR}/backports/__init__.py"
+
+BBCLASSEXTEND = "native nativesdk"