summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-beautifulsoup4_4.8.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-beautifulsoup4_4.8.2.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-beautifulsoup4_4.8.2.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-beautifulsoup4_4.8.2.bb b/external/meta-python2/recipes-devtools/python/python-beautifulsoup4_4.8.2.bb
new file mode 100644
index 00000000..9f9065e2
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-beautifulsoup4_4.8.2.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Screen-scraping library"
+DESCRIPTION = "Beautiful Soup is a library that makes it easy to scrape \
+information from web pages. It sits atop an HTML or XML parser, providing \
+Pythonic idioms for iterating, searching, and modifying the parse tree."
+HOMEPAGE = " https://www.crummy.com/software/BeautifulSoup/bs4"
+SECTION = "devel/python"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING.txt;md5=f2d38d8a40bf73fd4b3d16ca2e5882d1"
+
+SRC_URI[md5sum] = "5dbdb56c009e4632bae7bed1b385804b"
+SRC_URI[sha256sum] = "05fd825eb01c290877657a56df4c6e4c311b3965bda790c613a3d6fb01a5462a"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-html5lib \
+ ${PYTHON_PN}-lxml \
+ ${PYTHON_PN}-soupsieve \
+"
+
+RDEPENDS_${PN}_append_class-target = "\
+ ${PYTHON_PN}-html \
+ ${PYTHON_PN}-logging \
+"
+
+BBCLASSEXTEND = "native nativesdk"