summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-booleanpy_3.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-booleanpy_3.7.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-booleanpy_3.7.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-booleanpy_3.7.bb b/external/meta-python2/recipes-devtools/python/python-booleanpy_3.7.bb
new file mode 100644
index 00000000..b80e4344
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-booleanpy_3.7.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Define boolean algebras, create and parse boolean expressions and create custom boolean DSL"
+HOMEPAGE = "https://github.com/bastikr/boolean.py"
+
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e319747a5eb94cddf646037c01ddba47"
+
+SRC_URI += "file://run-ptest"
+SRC_URI[md5sum] = "1189d115a38f84f5df743014926a9159"
+SRC_URI[sha256sum] = "bd19b412435611ecc712603d0fd7d0e280e24698e7a6e3d5f610473870c5dd1e"
+
+PYPI_PACKAGE = "boolean.py"
+
+inherit pypi setuptools ptest
+
+RDEPENDS_${PN}_append_class-target = "\
+ ${PYTHON_PN}-lang \
+"
+
+RDEPENDS_${PN}-ptest += "\
+ ${PYTHON_PN}-unittest \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/boolean
+ cp -rf ${S}/boolean/test_boolean.py ${D}${PTEST_PATH}/boolean/
+}
+
+FILES_${PN}-test = ""
+
+BBCLASSEXTEND = "native nativesdk"