summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-cffi_1.13.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-cffi_1.13.2.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-cffi_1.13.2.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-cffi_1.13.2.bb b/external/meta-python2/recipes-devtools/python/python-cffi_1.13.2.bb
new file mode 100644
index 00000000..c1d7e417
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-cffi_1.13.2.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Foreign Function Interface for Python calling C code"
+DESCRIPTION = "C Foreign Function Interface for Python. Interact with almost any C code from Python, based on C-like declarations that you can often copy-paste from header files or documentation."
+HOMEPAGE = "http://cffi.readthedocs.org/"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5677e2fdbf7cdda61d6dd2b57df547bf"
+
+SRC_URI[md5sum] = "652203cf99faa254efff7fab23c2f3a2"
+SRC_URI[sha256sum] = "599a1e8ff057ac530c9ad1778293c665cb81a791421f46922d80a86473c13346"
+
+DEPENDS += "libffi ${PYTHON_PN}-pycparser"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-subprocess \
+"
+
+RDEPENDS_${PN}_class-target = " \
+ ${PYTHON_PN}-ctypes \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-pycparser \
+ ${PYTHON_PN}-shell \
+"
+
+BBCLASSEXTEND = "native nativesdk"