summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-dateutil_2.8.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-dateutil_2.8.1.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-dateutil_2.8.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-dateutil_2.8.1.bb b/external/meta-python2/recipes-devtools/python/python-dateutil_2.8.1.bb
new file mode 100644
index 00000000..c265c3a6
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-dateutil_2.8.1.bb
@@ -0,0 +1,29 @@
+SUMMARY = "Extensions to the standard Python datetime module"
+DESCRIPTION = "The dateutil module provides powerful extensions to the \
+datetime module available in the Python standard library."
+HOMEPAGE = "https://dateutil.readthedocs.org"
+
+LICENSE = "BSD-3-Clause & Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3155c7bdc71f66e02678411d2abf996"
+
+SRC_URI[md5sum] = "f2a1d4b680b297b367a974664ca3a4f6"
+SRC_URI[sha256sum] = "73ebfe9dbf22e832286dafa60473e4cd239f8592f699aa5adaf10050e6e1823c"
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+
+PYPI_PACKAGE = "python-dateutil"
+
+inherit pypi setuptools
+
+PACKAGES =+ "${PN}-zoneinfo"
+FILES_${PN}-zoneinfo = "${libdir}/${PYTHON_DIR}/site-packages/dateutil/zoneinfo"
+
+
+RDEPENDS_${PN}_class-target = "\
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-stringold \
+"
+
+BBCLASSEXTEND = "native"