summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-flask-wtf_0.14.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-flask-wtf_0.14.2.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-flask-wtf_0.14.2.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-flask-wtf_0.14.2.bb b/external/meta-python2/recipes-devtools/python/python-flask-wtf_0.14.2.bb
new file mode 100644
index 00000000..23162c26
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-flask-wtf_0.14.2.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Simple integration of Flask and WTForms."
+DESCRIPTION = "Simple integration of Flask and WTForms, including CSRF, file \
+upload, and reCAPTCHA."
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3ca6bb31670492f791e6a9f2fb9f8a80"
+
+SRC_URI[md5sum] = "586f50f233926cade42e3d744aca3e8f"
+SRC_URI[sha256sum] = "5d14d55cfd35f613d99ee7cba0fc3fbbe63ba02f544d349158c14ca15561cc36"
+
+PYPI_PACKAGE = "Flask-WTF"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-flask \
+ ${PYTHON_PN}-itsdangerous \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-wtforms \
+"