summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-idna_2.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-idna_2.8.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-idna_2.8.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-idna_2.8.bb b/external/meta-python2/recipes-devtools/python/python-idna_2.8.bb
new file mode 100644
index 00000000..74ed8e3e
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-idna_2.8.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Internationalised Domain Names in Applications"
+HOMEPAGE = "https://github.com/kjd/idna"
+LICENSE = "BSD-3-Clause & Python-2.0 & Unicode"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=782775b32f96098512e283fb5d4546cd"
+
+SRC_URI[md5sum] = "2e9ae0b4a0b26d1747c6127cdb060bc1"
+SRC_URI[sha256sum] = "c357b3f628cf53ae2c4c05627ecc484553142ca23264e593d327bcde5e9c3407"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN}_class-target = "\
+ ${PYTHON_PN}-codecs \
+"
+
+# Remove bundled egg-info
+do_compile_prepend() {
+ rm -rf ${S}/idna.egg-info
+}
+
+BBCLASSEXTEND = "native nativesdk"