summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-jsonpatch_1.24.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-jsonpatch_1.24.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-jsonpatch_1.24.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-jsonpatch_1.24.bb b/external/meta-python2/recipes-devtools/python/python-jsonpatch_1.24.bb
new file mode 100644
index 00000000..8b280fa4
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-jsonpatch_1.24.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Appling JSON patches in Python 2.6+ and 3.x"
+HOMEPAGE = "https://github.com/stefankoegl/python-json-patch"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=32b15c843b7a329130f4e266a281ebb3"
+
+SRC_URI[md5sum] = "e86503f05fa192fa870d7004b8ce929a"
+SRC_URI[sha256sum] = "cbb72f8bf35260628aea6b508a107245f757d1ec839a19c34349985e2c05645a"
+
+inherit pypi setuptools
+
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-jsonpointer \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-re \
+ ${PYTHON_PN}-stringold \
+"