summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-mccabe_0.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-mccabe_0.4.0.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-mccabe_0.4.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-mccabe_0.4.0.bb b/external/meta-python2/recipes-devtools/python/python-mccabe_0.4.0.bb
new file mode 100644
index 00000000..6b63cd78
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-mccabe_0.4.0.bb
@@ -0,0 +1,20 @@
+SUMMARY = "McCabe checker, plugin for flake8"
+HOMEPAGE = "https://github.com/dreamhost/cliff"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://README.rst;md5=f8b50fba1711ecac6bcdb6324f85a66d"
+
+SRC_URI += " \
+ file://0001-python-mccabe-remove-unnecessary-setup_requires-pyte.patch \
+"
+
+SRC_URI[md5sum] = "8c425db05f310adcd4bb174b991f26f5"
+SRC_URI[sha256sum] = "9a2b12ebd876e77c72e41ebf401cc2e7c5b566649d50105ca49822688642207b"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} += " \
+ python-prettytable \
+ python-cmd2 \
+ python-pyparsing"
+
+BBCLASSEXTEND = "native nativesdk"