summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-networkx_2.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-networkx_2.2.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-networkx_2.2.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-networkx_2.2.bb b/external/meta-python2/recipes-devtools/python/python-networkx_2.2.bb
new file mode 100644
index 00000000..c8d36192
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-networkx_2.2.bb
@@ -0,0 +1,14 @@
+SUMMARY = "Python package for creating and manipulating graphs and networks"
+DESCRIPTION = "NetworkX is a Python package for the creation, manipulation, \
+and study of the structure, dynamics, and functions of complex networks."
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3376ff7c9c58048c62d91431f7f08cde"
+
+SRC_URI[md5sum] = "82608a3686fb3e61f20cf13bfd3c1b4a"
+SRC_URI[sha256sum] = "45e56f7ab6fe81652fb4bc9f44faddb0e9025f469f602df14e3b2551c2ea5c8b"
+
+inherit pypi setuptools
+
+PYPI_PACKAGE_EXT = "zip"
+
+RDEPENDS_${PN} += "${PYTHON_PN}-decorator"