summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-packaging_20.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-packaging_20.0.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-packaging_20.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-packaging_20.0.bb b/external/meta-python2/recipes-devtools/python/python-packaging_20.0.bb
new file mode 100644
index 00000000..e19bca30
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-packaging_20.0.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Core utilities for Python packages"
+DESCRIPTION = "The packaging project includes the following: version handling, \
+specifiers, markers, requirements, tags, utilities."
+HOMEPAGE = "https://github.com/pypa/packaging"
+LICENSE = "Apache-2.0 & BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=faadaedca9251a90b205c9167578ce91"
+
+SRC_URI[md5sum] = "93d6ccbdfcb5b7697b6ecea53ecc294b"
+SRC_URI[sha256sum] = "fe1d8331dfa7cc0a883b49d75fc76380b2ab2734b220fbb87d774e4fd4b851f8"
+
+inherit pypi setuptools
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+
+RDEPENDS_${PN} += "${PYTHON_PN}-six ${PYTHON_PN}-pyparsing"