summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-pexpect_4.7.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-pexpect_4.7.0.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-pexpect_4.7.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-pexpect_4.7.0.bb b/external/meta-python2/recipes-devtools/python/python-pexpect_4.7.0.bb
new file mode 100644
index 00000000..3efdafd2
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-pexpect_4.7.0.bb
@@ -0,0 +1,23 @@
+SUMMARY = "A Pure Python Expect like Module for Python"
+HOMEPAGE = "http://pexpect.readthedocs.org/"
+SECTION = "devel/python"
+LICENSE = "ISC"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1c7a725251880af8c6a148181665385b"
+
+SRC_URI[md5sum] = "ed003242cbf308aee1b1eaecdef59e43"
+SRC_URI[sha256sum] = "9e2c1fd0e6ee3a49b28f95d4b33bc389c89b20af6a1255906e90ff1262ce62eb"
+
+UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/pexpect"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-terminal \
+ ${PYTHON_PN}-resource \
+ ${PYTHON_PN}-fcntl \
+ ${PYTHON_PN}-ptyprocess \
+"
+
+BBCLASSEXTEND = "native nativesdk"