summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-pint_0.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-pint_0.9.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-pint_0.9.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-pint_0.9.bb b/external/meta-python2/recipes-devtools/python/python-pint_0.9.bb
new file mode 100644
index 00000000..71ddf547
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-pint_0.9.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Physical quantities module"
+DESCRIPTION = "Pint is a Python package to define, operate and manipulate \
+physical quantities: the product of a numerical value and a unit of \
+measurement. It allows arithmetic operations between them and conversions from \
+and to different units. \
+\
+It is distributed with a comprehensive list of physical units, prefixes and \
+constants. Due to its modular design, you can extend (or even rewrite!) the \
+complete list without changing the source code. It supports a lot of numpy \
+mathematical operations without monkey patching or wrapping numpy."
+HOMEPAGE = "https://github.com/hgrecco/pint"
+SECTION = "devel/python"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=bccf824202692270a1e0829a62e3f47b"
+
+PYPI_PACKAGE = "Pint"
+
+SRC_URI[md5sum] = "d0681cb7cfaca9fc68ce7edab0d08d88"
+SRC_URI[sha256sum] = "32d8a9a9d63f4f81194c0014b3b742679dce81a26d45127d9810a68a561fe4e2"
+
+inherit pypi setuptools
+
+BBCLASSEXTEND = "native"