summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-protobuf_3.9.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-protobuf_3.9.2.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-protobuf_3.9.2.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-protobuf_3.9.2.bb b/external/meta-python2/recipes-devtools/python/python-protobuf_3.9.2.bb
new file mode 100644
index 00000000..84ce2201
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-protobuf_3.9.2.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Protocol Buffers"
+DESCRIPTION = "Protocol Buffers are Google’s data interchange format"
+HOMEPAGE = "https://developers.google.com/protocol-buffers/"
+SECTION = "devel/python"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=19e8f490f9526b1de84f8d949cfcfd4e"
+
+inherit pypi setuptools
+
+SRC_URI[md5sum] = "d634666c898148e4565ac62f3ba4a2ca"
+SRC_URI[sha256sum] = "843f498e98ad1469ad54ecb4a7ccf48605a1c5d2bd26ae799c7a2cddab4a37ec"
+
+# http://errors.yoctoproject.org/Errors/Details/184715/
+# Can't find required file: ../src/google/protobuf/descriptor.proto
+CLEANBROKEN = "1"
+
+UPSTREAM_CHECK_REGEX = "protobuf/(?P<pver>\d+(\.\d+)+)/"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-pkgutil \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-unittest \
+"
+
+# For usage in other recipies when compiling protobuf files (e.g. by grpcio-tools)
+BBCLASSEXTEND = "native nativesdk"
+