summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-pycodestyle_2.5.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-pycodestyle_2.5.0.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-pycodestyle_2.5.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-pycodestyle_2.5.0.bb b/external/meta-python2/recipes-devtools/python/python-pycodestyle_2.5.0.bb
new file mode 100644
index 00000000..38ed8439
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-pycodestyle_2.5.0.bb
@@ -0,0 +1,21 @@
+
+SUMMARY = "Python style guide checker (formly called pep8)"
+HOMEPAGE = "https://pypi.org/project/pycodestyle"
+LICENSE = "MIT"
+SECTION = "devel/python"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=01831ddbaf398471da3cc87f5037e822"
+
+SRC_URI[md5sum] = "40e7a76f364a18f531aaba11a4476e21"
+SRC_URI[sha256sum] = "e40a936c9a450ad81df37f549d676d127b1b66000a6c500caa2b085bc0ca976c"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} += "${PYTHON_PN}-lang"
+
+do_install_append () {
+ if [ -f ${D}${bindir}/pycodestyle ]; then
+ mv ${D}${bindir}/pycodestyle ${D}${bindir}/pycodestyle-2
+ fi
+}
+
+BBCLASSEXTEND = "native nativesdk"