summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-pycparser_2.19.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-pycparser_2.19.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-pycparser_2.19.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-pycparser_2.19.bb b/external/meta-python2/recipes-devtools/python/python-pycparser_2.19.bb
new file mode 100644
index 00000000..63c5a681
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-pycparser_2.19.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Parser of the C language, written in pure Python"
+HOMEPAGE = "https://github.com/eliben/pycparser"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86f1cedb4e6410a88ce8e30b91079169"
+
+SRC_URI[md5sum] = "76396762adc3fa769c83d8e202d36b6f"
+SRC_URI[sha256sum] = "a988718abfad80b6b157acce7bf130a30876d27603738ac39f140993246b25b3"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN}_class-target += "\
+ ${PYTHON_PN}-ply \
+ ${PYTHON_PN}-pprint \
+ ${PYTHON_PN}-subprocess \
+ cpp \
+ cpp-symlinks \
+ "
+
+BBCLASSEXTEND = "native nativesdk"