summaryrefslogtreecommitdiffstats
path: root/external/meta-python2/recipes-devtools/python/python-pymysql_0.9.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'external/meta-python2/recipes-devtools/python/python-pymysql_0.9.3.bb')
-rw-r--r--external/meta-python2/recipes-devtools/python/python-pymysql_0.9.3.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/external/meta-python2/recipes-devtools/python/python-pymysql_0.9.3.bb b/external/meta-python2/recipes-devtools/python/python-pymysql_0.9.3.bb
new file mode 100644
index 00000000..df879136
--- /dev/null
+++ b/external/meta-python2/recipes-devtools/python/python-pymysql_0.9.3.bb
@@ -0,0 +1,19 @@
+
+SUMMARY = "A pure-Python MySQL client library"
+DESCRIPTION = " \
+ This package contains a pure-Python MySQL client library, based on PEP 249 \
+ Most public APIs are compatible with mysqlclient and MySQLdb. \
+ "
+SECTION = "devel/python"
+HOMEPAGE = "https://pymysql.readthedocs.io"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=528175c84163bb800d23ad835c7fa0fc"
+
+SRC_URI[md5sum] = "e5d9183cc0a775ac29f9e0365cca6556"
+SRC_URI[sha256sum] = "d8c059dcd81dedb85a9f034d5e22dcb4442c0b201908bede99e306d65ea7c8e7"
+
+inherit pypi setuptools
+
+PYPI_PACKAGE = "PyMySQL"
+
+RDEPENDS_${PN} += "${PYTHON_PN}-cryptography"